Модель мониторинга, удалённого управления и голосовой связи в локальных компьютерных классах на основе программного обеспечения Lingo

Получена: 2026-05-16

Опубликована: 2026-06-06

Аннотация

В статье исследована практическая модель использования программного обеспечения Lingo для управления локальным компьютерным классом и лингафонными занятиями. Были проанализированы модули RemoteServer и RemoteClient, конфигурационные файлы, исходные коды на Java, компоненты медиа-тестирования, а также запускные пакеты Teacher.exe и Student.exe, входящие в состав готового проекта.


Программа организует компьютер преподавателя как центральную точку управления, а компьютеры учащихся — как клиентские устройства. Ее функциональные возможности связаны с мониторингом экранов, удалённым управлением выбранным компьютером, передачей голоса всем учащимся, созданием индивидуального или группового голосового общения, а также запуском тестовых модулей.


В исследовании применялись методы контент-анализа, модульного анализа на уровне кода и архитектурного моделирования. В результате система Lingo была оценена как программное решение, позволяющее преподавателю оперативно и централизованно управлять практическим занятием в компьютерном классе. Вместе с тем была обоснована необходимость совершенствования системы в направлениях аутентификации, шифрования, политики портов, журнала сессий и оптимизации сетевого трафика.

Список литературы

  1. Oracle. (n.d.). ServerSocket (Java Platform SE 8). Oracle Java Documentation. Retrieved May 16, 2026, from https://docs.oracle.com/javase/8/docs/api/java/net/ServerSocket.html

  2. Postel, J. (1981). Transmission Control Protocol. RFC 793. Internet Engineering Task Force. https://doi.org/10.17487/RFC0793

  3. Postel, J. (1980). User Datagram Protocol. RFC 768. Internet Engineering Task Force. https://doi.org/10.17487/RFC0768

  4. Oracle. (n.d.). Robot (Java Platform SE 8). Oracle Java Documentation. Retrieved May 16, 2026, from https://docs.oracle.com/javase/8/docs/api/java/awt/Robot.html

  5. Oracle. (n.d.). ObjectOutputStream (Java Platform SE 8). Oracle Java Documentation. Retrieved May 16, 2026, from https://docs.oracle.com/javase/8/docs/api/java/io/ObjectOutputStream.html

  6. Oracle. (n.d.). Lesson: Using Swing Components. The Java Tutorials. Retrieved May 16, 2026, from https://docs.oracle.com/javase/tutorial/uiswing/components/index.html

  7. Goodyear, P., Jones, C., & Thompson, K. (2013). Computer-supported collaborative learning: Instructional approaches, group processes and educational designs. In J. M. Spector, M. D. Merrill, J. Elen, & M. J. Bishop (Eds.), Handbook of Research on Educational Communications and Technology (pp. 439-452). Springer.

  8. Jeong, H., & Hmelo-Silver, C. E. (2016). Seven affordances of computer-supported collaborative learning: How to support collaborative learning? Educational Psychologist, 51(2), 247-265. https://doi.org/10.1080/00461520.2016.1158654

  9. Xu, L. (2016). Java Remote Control System [Bachelor’s thesis, Lahti University of Applied Sciences]. Theseus Repository.

  10. Sharda, R., Delen, D., & Turban, E. (2020). Analytics, Data Science, & Artificial Intelligence: Systems for Decision Support (11th ed.). Pearson.

Об авторах

Мухамеджонова Зухра
Ташкентский университет информационных технологий имени Мухаммада аль-Хорезми, кафедра “Телевизионные и медиа технологии”, магистрант
Фахриддин Нуралиев
Ташкентский университет информационных технологий имени Мухаммада аль-Хорезми, кафедра телевизионных и медиа технологий, доктор технических наук, профессор.
Фарход Хотамов
Ташкентский университет информационных технологий имени Мухаммада аль-Хорезми, кафедра телевизионных и медиа технологий, докторант.
Мухамеджонова Фотима
Ташкентский университет информационных технологий имени Мухаммада аль-Хорезми, кафедра “Телевизионные и медиа технологии”, магистрант

Лицензия

Как цитировать

Модель мониторинга, удалённого управления и голосовой связи в локальных компьютерных классах на основе программного обеспечения Lingo. (2026). MMIT Proceedings, 1089-1094. https://doi.org/10.61587/

Похожие статьи

Вы также можете начать расширеннвй поиск похожих статей для этой статьи.

Наиболее читаемые статьи этого автора (авторов)